LMS 7.9 auf QNAP-NAS

karlek
Beiträge: 1255
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Duet
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

LMS 7.9 auf QNAP-NAS

Beitrag von karlek » 11. August 2017 18:15

Ja, mach mal.
Deine Rückfrage hat mich neugierig gemacht und so habe ich noch ein wenig gelesen.
Im Prinzip sollte LMS auch auf einem 64Bit-System laufen. Das Problem ist, dass SSOTS sein eigenes Perl mitbringt, und das ist 32 Bit.
Für den normalen Betrieb stört das anscheinend nicht, nur wenn das Format konvertiert werden muss.
Also, ja, versuche es mal und melde Dich, wenn es geklappt hat und / oder Du auf weitere Fehler stößt.

dirk15
Beiträge: 1
Registriert: 26. Februar 2017 13:28
SqueezeBox: SqueezePlay
SqueezeBox Server läuft auf: Qnap TS-451+
Wohnort: Travemünde

Re: LMS 7.9 auf QNAP-NAS

Beitrag von dirk15 » 20. August 2017 11:23

Bitte um Unterstützung

Moin, ich habe den LMS in der Version 7.7.2 auf einem QNAP TS-451 installiert.
Das System läuft.

Allerdings werden meine Songs nicht erkannt/gefunden, obwohl ich meine die Pfade korrekt eingerichtet zu haben.

Außerdem möchte ich auf die aktuelle Version updaten und komme mit der hier geposteten Anleitung nicht klar, weil ich zu unerfahren mit Putty und Linux bin.
Habe ich die richtige Downloaddatei ausgewählt?
Sie liegt in Public, wird vom soss-Tool aber nicht gefunden.
Die Auswahl und "Upload" führt zu einer Fehlermeldung.
Eine Datei "routines.sh" finde ich, sie ist aber leer (oder erzeuge ich sie unbewusst?).
...


Ich bin auf der Suche nach jemandem der mir hilfreiche Tipps gibt, im Forum oder als PN.
Bitte!

Dirk aus Travemünde

karlek
Beiträge: 1255
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Duet
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

LMS 7.9 auf QNAP-NAS

Beitrag von karlek » 20. August 2017 20:21

Welchen Pfad hast Du denn im LMS für Deine Musiktitel angegeben?

Ich nahm für QNAP immer den größten Tarball mit CPAN. Welchen hast Du versucht?
Wenn Du die routines.sh nicht änderst, wird SSOTS sie nicht erkennen. Suche mal unter /opt/ssods4/ statt unter /share/.../.qpkg/LogitechMediaserver. Der Pfad unterscheidet sich bei QNAP nämlich an der Stelle, wo die drei Punkte sind, in Abhängigkeit vom Betriebssystem und wie man die Festplatten eingerichtet hat (Raid, einzeln, ...). Wenn Du da was anderes hast, als in dieser Anleitung, wird vi eine neue, leere Datei erstellen.
Und es muss auch wirklich ssods4 lauten, weil es ursprünglich für eine Diskstation, nicht für eine Turbostation entwickelt wurde.

Benutzeravatar
Lekubu
Beiträge: 2
Registriert: 4. September 2017 18:25
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Duet
SqueezeBox: Boom
SqueezeBox Server läuft auf: QNAP TS-421

Re: LMS 7.9 auf QNAP-NAS

Beitrag von Lekubu » 4. September 2017 19:27

Ich habe dasselbe Problem wie Dirk aus Travemünde:

Ich hab's geschafft, LMS 7.7.6 zum Laufen zu bringen. Die Internet-Radiosender kann ich abrufen, doch meine eigenen Songs werden nicht gefunden.
Sie liegen auf dem QNAP-NAS in einem Ordner namens "SQUEEZEBOX". Bei den Einstellungen der LMS-Seite habe ich diesen Ordner dann auch angegeben. Er erscheint unter /share/SQUEEZEBOX
Doch nach der Dateisuche bleibt der Musikordner beim LMS und in den angeschlossene Squeezebox-Geräten leer.

Was mache ich bloß falsch? Ich bin ratlos.
An den Leserechten des SQUEEZEBOX-Ordners wird's wohl kaum liegen.
Selbst wenn ich einzelne Songs in den Public-Ordner des NAS schiebe und ihn als zweiten Musikordner angebe, werden sie vom LMS nicht gefunden.

Danke für die Hilfe!!

karlek
Beiträge: 1255
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Duet
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS 7.9 auf QNAP-NAS

Beitrag von karlek » 4. September 2017 23:14

Also, zunächst einmal hat Dirk aus Travemünde ein anderes Problem. Bei ihm findet der SSOTS die Updates nicht. Bei Dir wird vom LMS keine Musik in die Datenbank eingetragen.

Letzteres kann diverse Gründe haben.
Als erstes würde ich mir mal das Scannerlog ansehen und auf Fehler untersuchen.
Es kann z.B. an einem fehlerhaften Coverbild liegen.
Oder Du hast im selben Verzeichnisbaum /share/SQUEEZEBOX auch Deine playlists und da stoßen welche dem Scanner auf.
Oder es ist doch was mit dem Verzeichnis. Der user ssods sollte zumindest Lesezugriff auf den Ordner haben.

Und was ganz anderes: Warum aktualisierst Du nicht auf die aktuelle release 7.9.0 oder am besten auf die aktuelle 7.9.1? Die sind tausend mal besser als die 7.7.6. Ich glaube es zwar nicht unbedingt, aber eventuell wird dadurch schon Dein Problem gelöst.

Benutzeravatar
Lekubu
Beiträge: 2
Registriert: 4. September 2017 18:25
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Duet
SqueezeBox: Boom
SqueezeBox Server läuft auf: QNAP TS-421

Re: LMS 7.9 auf QNAP-NAS

Beitrag von Lekubu » 6. September 2017 18:41

Ein großes DANKE an karlek für die Antwort.
Inzwischen bin ich alles durchgegangen.
Es liegt offensichtlich am Lesezugriff auf den Ordner. Obwohl ich ssots für den Ordner samt Unterordnern volle Zugriffsrechte erteilt hatte, kann der Mediaserver die meisten Unterordner im Verzeichnis gar nicht erst erkennen. Wenn ich auf der Seite LMS-IP:9001 bei den Einstellungen den Medienordner angeben will, sehe ich nur 4 von 20 Unterordnern. Und bei den 4 erkannten Ordner gibt es teilweise den Hinweis:
Permission denied at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/CPAN/File/Next.pm line 217.

Ich fürchte, das wird nichts mit meinem TS 421. Denn ich kann auch ich die angegebenen 7.9.0 und 7.9.1 nicht installieren. Die Anpassung der speziellen Datei (Eintrag der "9" über die "putty"-Software) habe ich gemäß Anleitung vorgenommen.
Denn scheint da etwas nicht kompatibel zu meinem Prozessor (armv5tel-linux). SSOTS empfiehlt nach dem Entpacken jeweils eine andere tar ball, auch wenn ich die arm-Version wähle (logitechmediaserver-7.9.1-1504317335-arm-linux.tgz). Die Fehlermeldung bei ssots heißt:
cannot determine what we just extracted. Try again (possibly with another tar ball).

Na ja, ich muss jetzt wohl aufgeben.
Trotzdem nochmals vielen Dank für die Unterstützung.

karlek
Beiträge: 1255
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Duet
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

LMS 7.9 auf QNAP-NAS

Beitrag von karlek » 6. September 2017 19:28

Ich glaube, ich weiß was mit Deinen Berechtigungen nicht stimmt. Du hast diese komische - ich kenne sie mal "hierarchische ", weil ich die genaue Bezeichnung nicht mehr kenne- Ordnerberechtigung eingerichtet. Dabei kommt es zu Problemen.
Edit: Das meinte ich (Hervorhebungen von mir):
- Sometimes the music(folder) is not visable, when using advanced user rights. Many thanks to Spag for the following solution:
1. Download and install WinSCP: http://winscp.net/
2. Log in to the QNAP NAS with admin user and password
3. Navigate to your music and playlist root folder(s)
4. Right click the folder(s) and set the octal settings to "0770" and set group, owner and permissions recursively. The most important thing is, that you set the group to "everyone [100]" and the owner to a local user, that is not the admin. If the group and owner are admin, squeezebox will not find any files.
5. Set the correct music and playlist folders in the Squeezbox Server's settings page.
Quelle: https://forum.qnap.com/viewtopic.php?f=123&t=35740 (Kann man nur erreichen, wenn man angemeldet ist.)

Beim Update gibst Du bitte nicht auf. Ich bin mir fast sicher, dass es funktioniert, wenn Du aus "logitechmediaserver" "squeezeboxserver" machst.

Achso: der User heißt ssods, nicht ssots.