Media Server bleibt seit einigen Tagen ständig stehen

nick_riviera
Beiträge: 15
Registriert: 15. Mai 2012 16:01
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: SqueezePlay
SqueezeBox Server läuft auf: Windows 7 PC mit Wake On LAN

Media Server bleibt seit einigen Tagen ständig stehen

Beitrag von nick_riviera »

hallo,

vor einiger Zeit habe ich meinen alten Media-PC ausgemustert, und den Logitech Media Server auf einem Synology DS216 Play installiert. Bis vor einigen Tagen funktionierte das auch einwandfrei, jetzt bleibt der Server aber ein bis zweimal am Tag einfach stehen, und man muss ihn manuell wieder starten.

Beim PC konnte ich den Media Server als Dienst mit Autostart installieren und vergessen. Hier finde ich aber nirgendwo die Einstellungen für das Startverhalten des Servers. Hat jemand eine Idee ?

Bei den Server-Einstellungen des Media Servers leuchtet sei heute eine Warnmeldung, dass eine oder mehrere Squeezeboxen mit einer veralteten Firmware bei mir unterwegs sind, die nicht mit dem verwendeten Media Server kompatibel sind. Die in den Einstellungen gepostete Anleitung funktioniert nicht - den Patch Installer kann ich noch installieren, wenn ich "Version Comparison Fix" installieren will, kommt nur die Meldung "No Patches Found". Wenn der Server läuft, verbinden sich auch alles Squeezeboxen problemlos mit dem Server, Verbindungsprobleme wie in der Patch-Anleitung angekündigt, gibt es nicht. Das wirklich einzige Problem ist, dass plötzlich auf allen Boxen die Musik weg ist, weil der Server von alleine anhält.

Das System des NAS ist DSM 6.2.3-25426 Update 2, die Media-Server-Version ist 8.0.0, die Firmware der Radios ist Version 7.7.3 r16676, bei der Boom müsste ich noch nachsehen. Wenn Ihr eine Idee habt, was ich tun kann, damit der Server nicht mehr stoppt, bin ich für jeden Tipp dankbar. Zwar ist das Starten des Servers dank Smartphone nicht so eine Sache, es nervt aber, wenn man mal eben morgens die Nachrichten hören will, und im Halbschlaf zu basteln anfangen muss.

Danke und Gruß Frank
karlek
Moderator
Beiträge: 2091
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Media Server bleibt seit einigen Tagen ständig stehen

Beitrag von karlek »

Du könntest mal in Serverlog nachsehen, was vor dem Stoppen der Musik so alles passiert. Normal ist das nämlich nicht. Vermutlich stoppt der LMS auch nicht, sondern hängt.
Passiert das bei bestimmten Radiosendern oder hörst Du eigene Musik, oder Titel von Spotify, oder so? Oder passiert es während eines Scans?
Die 8.0.x ist auch schon wieder recht alt. Kannst Du auf 8.2 aktualisieren?
nick_riviera
Beiträge: 15
Registriert: 15. Mai 2012 16:01
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: SqueezePlay
SqueezeBox Server läuft auf: Windows 7 PC mit Wake On LAN

Re: Media Server bleibt seit einigen Tagen ständig stehen

Beitrag von nick_riviera »

erstmal danke für die Antwort.

In der Systemsteuerung war unter "Dienste" das Häkchen "Aktivieren" für den LMS nicht gesetzt - ich bin mir sicher, dass es gesetzt war, als ich das Paket installiert habe.

Nach dem Setzen des Häkchens startete der LMs sofort wieder, im Gegensatz zu den manuellen Starts liefen die Squeezeboxen aber nicht einfach wieder, sondern waren alle irgendwie "abgestürzt". Die kleinen Radios haben die Musik leise und ohne Bässe gespielt, die Boom hat nur noch Krachen und Zischen von sich gegeben, und die Duet an der Anlage lief überhaupt nicht mehr an. Alle mussten runter- und wieder hoch gefahren werden, danach war alles wieder ok, rund drei Wochen lang. Heute stand der Medienserver wieder ( er hing nicht nur, sondern war richtig gestoppt ), und das Häkchen "Aktivieren" war wieder weg.

Ich habe dann zuerst mal den Server manuell gestartet, danach liefen alle Squeezeboxen wieder. Als ich aber den Haken bei Dienst/Aktivieren gesetzt habe, und der Server dadurch automatisch hochfuhr, waren wieder alle Squeezeboxen queer und mussten neu gebootet werden.

Ich habe die Dinger eigentlich nur noch zum Radiohören und wegen der Synchron-Funktion im Einsatz, so langsam wird es aber glaube ich Zeit, das System in Rente zu schicken - zumal man ja Musikdienste eh nicht vernünftig nutzen kann.

Das NAS selber läuft einwandfrei, ich glaube nicht, dass es daran liegt.

Gruß Frank