Squeezeboxen plötzlich langsam bei Starten des SQL Playlist Zufallsmixes.

HKNBG
Beiträge: 120
Registriert: 20. April 2020 13:50
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox Server läuft auf: Raspberry Pi/Linux

Squeezeboxen plötzlich langsam bei Starten des SQL Playlist Zufallsmixes.

Beitrag von HKNBG »

Hallo zusammen,

in den letzten Tagen habe ich meine mp3 Dateien aktualisiert und die mp3 Tags verändert und Albumcover, Alben und Namen der Titel verändert. Soweit hat alles gut funktioniert. Vor 2 Tagen habe ich dann noch meine Fritzbox auf die aktuelle Version geändert. Somit wird nun auch von der Fritzbox Samba 2 und 3 unterstüzt und kann nun über Samba 3.0 auf meine Musik auf dem Fritz-Nas zugreifen.

Als letztes habe ich heute noch heute die Lautstärkennormalisierung durchgeführt (mit Foobar 2000). Nun bin ich endlich fertig.

Dennoch ist noch das Problem da, was ich in der Überschrift beschrieben habe. Die Zufallsmixe habe ich auf die Schnellauswahltasten auf dem Radio gelegt.
Wenn ich nun auf die Tasten drücke (auch bei Auswahl über die Einstellungen dauert es so lange), dass der Zufallsmix startet, dauert es ca. 5 Sekunden. Bis das Albumcover geladen ist, dauert es noch länger. Bis vor ein paar Tagen hat es nur ca. 1-2 Sekunden gedauert.

Ich habe bereits diese Sachen ausprobiert:
- Reboot des Servers (Raspberry Pi)
- Durchsuchen Wiederholen (komplette Datenbank löschen und neu einlesen)
- Verfügbares Update für den Server installieren
- Wechsel zum Backup ohne Lautstärkennormalisierung (ein BAckup, wo alles gleich ist; nur keine Lautstärkennormalisierung durchgeführt wurde) und zum Uralt-Backup, wo keine Albencover dabei sind (dieses kann ich eigentlich löschen; war jetzt aber zum ausprobieren nicht schlecht). Danach selbstverständlich neu durchsuchen.
- Erneuter Wechsel von Samba 3.0 zu Samba 1.0
- Ausprobieren des normalen Zufallsmixes von Logitech, den ich eigentlich bereits entfernt habe. Dort starten die Lieder minimal schneller. Bis das Albumcover auf dem Radio erscheint, dauert es aber noch länger (ich weiß, eigenartige Kombination).

Dennoch hat sich nie etwas geändert. Bis die Lieder starten, dauert es ca 2-3 Mal länger, als vor ein paar Tagen. Hat irgendwer eine Lösung oder eventuell das gleiche Problem?
Mit freundlichen Grüßen
HKNBG
karlek
Moderator
Beiträge: 1947
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Squeezeboxen plötzlich langsam bei Starten des SQL Playlist Zufallsmixes.

Beitrag von karlek »

Was mir da jetzt spontan in den Sinn kommt, wäre caching.
Vermutlich muss durch Deine umfangreichen Änderungen der cache neu aufgebaut werden. Bis das der Fall ist, dauert alles ein wenig länger.
Also warte ein bisschen ab und schau, obs besser wird.

DISCLAIMER:
Das ist alles aus dem hohlen Bauch und muss weder Hand noch Fuß haben. :oops:
HKNBG
Beiträge: 120
Registriert: 20. April 2020 13:50
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox Server läuft auf: Raspberry Pi/Linux

Re: Squeezeboxen plötzlich langsam bei Starten des SQL Playlist Zufallsmixes.

Beitrag von HKNBG »

Hallo Karlek,

danke für deine Antwort. Das waren auch meine Überlegungen. Die Tags habe ich nicht alle auf Einmal geändert. Das ganze hat sich in den letzten 3 Monaten etwas hingezogen. Somit gab es keine großen Veränderungen auf Einmal. Das Einzige, was ich wirklich alles auf Einmal gemacht habe, war die Lautstärke Normalisierung. Bei einem wechsel zu dem Backup sollte allerdings doch alles wieder wir zuvor sein. (Ich habe im gleichen Order alle Lieder nochmals gespeichert; nur unter einem anderen Ordnernamen. Diesen habe ich dann testweise so umbenannt, dass er so heißt, dass das LMS darauf zugreift/wie vor der Normalisierung)

Somit sollte es doch eigentlich nixht daran liegen, oder?


Ganz nebenbei: Kann man eigentlich ohne großen Aufwand von LMS 8.0 auf 7.9 wechseln, oder musss man dann den LMS komplett neu aufsetzen. Ich denke die LMS 8.0 Beta wird nie eine Vollversion, oder doch?
Mit freundlichen Grüßen
HKNBG
karlek
Moderator
Beiträge: 1947
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Squeezeboxen plötzlich langsam bei Starten des SQL Playlist Zufallsmixes.

Beitrag von karlek »

HKNBG hat geschrieben: 12. Juli 2020 23:00 Hallo Karlek,

danke für deine Antwort. Das waren auch meine Überlegungen. Die Tags habe ich nicht alle auf Einmal geändert. Das ganze hat sich in den letzten 3 Monaten etwas hingezogen. Somit gab es keine großen Veränderungen auf Einmal. Das Einzige, was ich wirklich alles auf Einmal gemacht habe, war die Lautstärke Normalisierung.
Naja, damit hast Du alle Titel nochmal angefasst. Kann schon die Ursache sein.
Bei einem wechsel zu dem Backup sollte allerdings doch alles wieder wir zuvor sein. (Ich habe im gleichen Order alle Lieder nochmals gespeichert; nur unter einem anderen Ordnernamen. Diesen habe ich dann testweise so umbenannt, dass er so heißt, dass das LMS darauf zugreift/wie vor der Normalisierung)

Somit sollte es doch eigentlich nixht daran liegen, oder?
Die Titel werden ja in einer Datenbank gespeichert. Wenn da das Datum der letzten Änderung mitgespeichert wird, hast Du sie schon wieder angefasst. ;)
Und auch wenn nicht, ist der Cache trotzdem verloren. Wenn's denn daran liegt. Wart halt mal ab. :)

Ganz nebenbei: Kann man eigentlich ohne großen Aufwand von LMS 8.0 auf 7.9 wechseln, oder musss man dann den LMS komplett neu aufsetzen.
Weiß nicht. Sollte eigentlich klappen. Ich bin noch bei 7.9.3 :oops:
Ich denke die LMS 8.0 Beta wird nie eine Vollversion, oder doch?
Weiß ich auch nicht. Aber es wird viel daran entwickelt. Ich glaube daran, dass das was wird. Aber mit Vollversionen tat sich Michael lange Zeit schwer. Die 7.9.3 ist ein nightly, somit auch irgendwie beta. Und die 7.9.1 war jahrelang beta...

Edit: Was hast Du denn für Probleme mit der Beta? Die solltest Du ggf. melden.
HKNBG
Beiträge: 120
Registriert: 20. April 2020 13:50
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox Server läuft auf: Raspberry Pi/Linux

Re: Squeezeboxen plötzlich langsam bei Starten des SQL Playlist Zufallsmixes.

Beitrag von HKNBG »

Na, dann warte ich mal ein bisschen. Vielleicht wird es ja etwas besser 😉

Bezüglich des Wechsels auf Version 7.9. Wie würde denn ein solcher Wechsel ablaufen? Kann ich einfach die Version herunterladen und dann installieren (wie ohne bereits bestehenden Server auf dem Raspberry Pi), oder muss mann dann wirklich den Server deinstallieren und erneut installieren.

Bezüglich den Problemen: Generell habe ich keine Probleme. Es ist nur so, dass ich jeden Tag ein Update erhalte. Generell habe ich nichts gegen Updates. 1x pro Tag ist aber schon sehr viel😉. Mit jedem Update KANN (nicht muss) natürlich ein Problem dazukommen. Behoben werden keine, wenn man keine Probleme bemerkt hat.😉

Theoretisch muss man natürlich die Updates nicht installieren. Wenn aber eines verfügbar ist, möchte man es irgendwie installieren 😉

Aber selbst, wenn es einfach geht, weiß ich nicht, ob ich es mache.
Mit freundlichen Grüßen
HKNBG
karlek
Moderator
Beiträge: 1947
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Squeezeboxen plötzlich langsam bei Starten des SQL Playlist Zufallsmixes.

Beitrag von karlek »

Wenn Du nicht Manns genug bist, ein Update auszusetzen, dann schalte die Anzeige aus oder wechsle auf 7.9.
Traust Du Dich aber eh nicht. :D