MultiLibary Tool erkennt die Lieder in der Bibliothek nicht

HKNBG
Beiträge: 120
Registriert: 20. April 2020 13:50
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox Server läuft auf: Raspberry Pi/Linux

MultiLibary Tool erkennt die Lieder in der Bibliothek nicht

Beitrag von HKNBG »

Hallo, ich benutze einen Squeezebox Server auf einem Raspberry.

Da ich gerne verschiedene Musikbibliotheken haben wollte, habe ich mir das MultiLibary Tool installiert. Leider habe ich das Problem, dass das Tool meine Lieder in den verschiedenen Ordnern nicht erkennt, wenn ich den Raspberry neustarte (Musikbibliotheken werden angezeigt; es werden aber 0 Lieder angezeigt. Dies hat zur Folge, dass man kein einziges Lied mehr hören kann, da er alle Lieder überspringt, wenn sie nicht in der Musikbibliothek sind/Kombination mit dem Custom Skip Plugin). Wenn ich dies mache, muss ich entweder den Server neustarten (nicht den Raspberry, sondern nur den Server), oder unter dem Tool im Web Interface die Bibliothek aktuelisieren.

Meine Vermutung: Da meine Lieder und Bibliotheken des MultiLibary-Tools auf dem Fritz-Nas liegen, habe ich das FritzNas gemountet. Daher versucht er auf die Ordner zuzugreifen; kann aber keine Lieder finden, da die Ordner erst ein paar Sekunden später gemountet werden.

Wenn ich in den Einstellungen des Raspberrys einstelle, dass er nur dann Booten soll, wenn eine Netzwerkverbindung besteht, würde es funktionieren. Dennoch möchte ich ungerne diese Einstellung aktivieren.

PS: Das gleiche Problem hatte ich auch mit dem Mounten des NAS. Dort habe ich es beheben können, indem ich in der Datei rc.local die Punkte

sleep 15
sudo mount -a

hinzugefügt habe

Weiß jemand eine vorgehensweise, wie man das Problem beheben kann?

Mit freundlichen Grüßen


Edit:

ich habe es nun hinbekommen. Ich habe noch nach in der Datei rc.local die Zeile "sudo /etc/init.d/logitehmediaserver restart" hinzugefügt. Somit heißt es jetzt gesamt:

sleep 15
sudo mount -a
sudo /etc/init.d/logitechmediaserver restart


Falls jedoch jemand noch die Möglichkein haben sollte den Boot Vorgang so zu verzögern, dass es direkt beim Booten gemacht wird, kann er es gerne noch Antworten :D
karlek
Moderator
Beiträge: 1947
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: MultiLibary Tool erkennt die Lieder in der Bibliothek nicht

Beitrag von karlek »

Ach, hastes schon gefunden? Gut!
Das wäre auch mein Vorschlag gewesen.

Nur ganz kurz: Dein Problem hat nichts mit MultiLibrary, oder so, zu tun. Das ist ein logisches Verhalten. Wenn das NAS nicht da ist, sind die mounts leere Verzeichnisse für den RasPi. Deine Analyse der Ursache war also korrekt. :)
Und ich glaube auch, dass beim Abspielen nicht verfügbare Titel auch ohne das Custom Skip-Plugin übersprungen würden.

Beide Bemerkungen von mir tragen nichts zur Lösung bei, ich weiß. Sie sollen aber sicherstellen, dass andere mit demselben Problem nicht in der falschen Richtung suchen.

Alternative Lösungsansätze für Dritte wären:
  • das NAS zuerst starten
  • das NAS nicht ausschalten
  • den RasPi nicht ausschalten
  • den RasPi auf eine bestehende Netzwerkverbindung warten lassen
Also, nichts für ungut!
HKNBG
Beiträge: 120
Registriert: 20. April 2020 13:50
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox Server läuft auf: Raspberry Pi/Linux

Re: MultiLibary Tool erkennt die Lieder in der Bibliothek nicht

Beitrag von HKNBG »

Hallo Karlek,

Vielen Dank für deine Antwort. Zwecks des MultiLibary Plugins und der Kombination mit dem CustomSkip Plugin übrspringt er die Lieder nur, wenn man in der MultiLibary auswählt, dass er überspringen soll. Dies kann man aber nur auswählen, wenn man einen "Überspringungsauftrag" mit CustomSkip erstellt. Somit hat das Tool aus meinen Augen keine Funktion mehr (Ausnahme: mit Kombination mit dem CustomBrowse Plugin kann man noch in die jeweiligen Bibliotheken bestimmte Lieder auswählen; Überspringen tut er dann aber nichts ;)

Mit freundlichen Grüßen
HKNBG
Mit freundlichen Grüßen
HKNBG
karlek
Moderator
Beiträge: 1947
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: MultiLibary Tool erkennt die Lieder in der Bibliothek nicht

Beitrag von karlek »

Danke für die Aufklärung. Das ganze Custom...- Zeug liegt auch noch auf meinem To Do-Stapel. Allerdings ganz weit unten. :-/
:)
HKNBG
Beiträge: 120
Registriert: 20. April 2020 13:50
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox Server läuft auf: Raspberry Pi/Linux

Re: MultiLibary Tool erkennt die Lieder in der Bibliothek nicht

Beitrag von HKNBG »

Bei mir ist auf jeden Fall ein Wochenende draufgegangen :lol:   :lol: . Das Custom-Zeug sind sehr gute Tools. Dennoch sind sie recht Kompliziert. Des Weiteren werden bei mir die Tools vom Erland Isaksson bis auf ein paar vereinzelte Tools nicht mehr verfügbar 🤷🤷. Ich musste sie jedenfalls manuell als Zip Datei herunterladen.
Dafür hat er jedoch eine ganz nette Website erstellt:

http://downloads.isaksson.info/download/

Die findet man aber leider nur so schwer.
Mit freundlichen Grüßen
HKNBG
karlek
Moderator
Beiträge: 1947
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: MultiLibary Tool erkennt die Lieder in der Bibliothek nicht

Beitrag von karlek »

Ja, er hat aufgehört zu entwickeln. Aber dass sein Repo nicht mehr vollständig ist, ist mir noch nicht aufgefallen.
Die URL kommt mir aber vage bekannt vor. Vermutlich hat er sie im slimdevices-Forum gepostet.