Massive WLAN-Probleme

Benutzeravatar
MarkusLehmann
Beiträge: 12
Registriert: 3. November 2012 21:46
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox Server läuft auf: Windows 11
Wohnort: Wolfach

Re: Massive WLAN-Probleme

Beitrag von MarkusLehmann »

Zuerst mal vielen Dank an alle, die auf der Suche nach Lösungen hier aktiv mitgewirkt haben - darunter war auch meine Problem-Lösung dabei :-)
Ich besitze 3 Logitech Squeezebox Radios, alle 3 hatte ich schon seit einigen Jahren auf UE Smart Radios geswitcht , weil mir diese Benutzeroberfläche besser gefallen hat.
Da alle 3 Radios nun seit dem letzten Update meiner FRITZ!Box 7590 auf die aktuelle FRITZ!OS Version 7.56 ständig nach einigen Minuten die WLAN-Verbindung verloren haben, galt es dir Ursache des Problems zu finden und zu beseitigen.
Die Variante von Thomas Holte habe ich mit meinem vorhandenen FRITZ!Repeater gleich getestet, d.h. ein Ende des LAN-Kabels in den Ethernet-Port der Squeezebox und das andere Ende in den FRITZ!Repeater, welcher über WLAN mit meiner FRITZ!Box verbunden ist. Funktioniert einwandfrei, kommt aber für mich nach einer kurze Testphase nicht auf Dauer in Frage, da diese Lösung eine zweite Stromversorgung erfordert und zusätzliche eine unnötige Strahlungsquelle darstellt.
Deshalb habe ich anschließend alles mögliche in den FRITZ!Box-Einstellungen versucht (feste IP-Adresse zuweisen, usw....) Alle Versuche egal welcher Art blieben leider erfolglos, möchte da jetzt nicht alles einzeln aufzählen, hat nur unnötig viel Zeit gekostet und letztendlich keinen Erfolg gebracht :-(
Daraufhin habe ich den "Workaround wlanpoke" von POMdev gesehen, und dachte das versuche ich jetzt einfach. Dabei musste ich jedoch gleich zum Start feststellen, dass es bei meinen UE Smart Radio Versionen unter "Einstellungen" - "Erweitert" gar keine "Remote-Anmeldung" gibt. Somit konnte ich den Workaround zuerst gar nicht ausführen. Deshalb habe ich zuerst eines der drei UE Smart Radio "zurück geswitcht" zum früheren Squeezebox Radio - und siehe da, schon hat es geklappt! Nachdem das erste Radio mit dem Workaround nun wieder zuverlässig läuft, habe ich es mit den beiden anderen Radios ebenso gemacht. Bisher laufen alle 3 Radios bestens, und ich hoffe es bleibt auch so. Ich bin aber auf Grund der positiven Berichte der anderen Nutzer, die auch den Workaround erfolgreich getestet haben, nun mal guter Zuversicht.
Hier der Link der vereinfachten (verständlicheren) Anleitung zur WLAN-Reparatur des Squeezebox Radios (wlanpoke) von rojikewl: https://forums.slimdevices.com/forum/us ... x-wlanpoke
Wer es lieber auf deutsch haben möchte soll einfach die Seite übersetzen lassen - so hab ich es auch gemacht ;-)
Ich wünsche nun allen, die das gleiche Problem haben, viel Erfolg, bei der jeweils für jeden einzelnen idealen Lösungsfindung!
Benutzeravatar
holte
Beiträge: 8
Registriert: 12. Oktober 2022 19:44
SqueezeBox: Radio
SqueezeBox Server läuft auf: QNAP-NAS unter QTS 5.0.1

Re: Massive WLAN-Probleme

Beitrag von holte »

@MarkusLehmann: wlanpoke war für mich keine Lösung, da es immer wieder zu kurzen Aussetzern beim Radiohören kam, wenn wlanpoke die WLAN-Verbindung neu aufgebaut hat. Passiert das bei dir denn nicht?
Freundliche Grüße
Thomas Holte 8-)
Benutzeravatar
MarkusLehmann
Beiträge: 12
Registriert: 3. November 2012 21:46
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox Server läuft auf: Windows 11
Wohnort: Wolfach

Re: Massive WLAN-Probleme

Beitrag von MarkusLehmann »

Bisher hab ich noch nichts festgestellt, vielleicht hängt das aber auch mit dem Puffer fürs Internetradio zusammen?
Ich denke wenn der zu kurz eingestellt wird es eher Aussetzer geben als mit einem etwas längeren Puffer.
Benutzeravatar
MarkusLehmann
Beiträge: 12
Registriert: 3. November 2012 21:46
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox Server läuft auf: Windows 11
Wohnort: Wolfach

Re: Massive WLAN-Probleme

Beitrag von MarkusLehmann »

Update 22.07.2023:
Tatsächlich scheint der Workaround "wlanpoke" von POMdev immer noch zu Aussetzern zu führen, komischerweise bei vielen Radiosendern so gut wie gar nicht, bei einigen wenigen dafür fast alle 15 Minuten.
Auch mein Radiowecker funktionierte nicht immer, häufig hat sich der nervige Standard-Weckton bei fehlender WLAN-Verbindung gemeldet, den ich jetzt mal durch einen anderen Alarmton ausgetauscht habe. Das funktioniert indem man im Radio-Verzeichnis "/usr/share/jive/applets/AlarmSnooze" die Datei "alarm.mp3" durch eine andere gleichlautende "alarm.mp3"-Datei ersetzt, mit einem schöneren Weckton. Sorry für die kleine Abschweifung, aber nichts Nervigeres, als durch einen Ton geweckt zu werden, den man überhaupt nicht ausstehen kann.
Nun bin ich auf diesen Thread von Tony T gestoßen: https://forums.slimdevices.com/forum/us ... disconnect
Anscheinend fehlt wohl nur ein Raute-Zeichen (#) an einer bestimmten Stelle im Pfad "/etc/init.d" in der Datei "wlan"
Ich bin dann wie folgt vorgegangen:
1) Den SSH-Server des Radios aktivieren: > Home > Einstellungen > Erweitert > Remote-Anmeldung > Auswahl von SSH aktivieren und dabei die IP-Adresse des Radios notieren, die auf dem Bildschirm in der folgenden Meldung angezeigt wird.
2) Das Programm "WinSCP" auf den Computer runterladen von der Seite https://winscp.net/eng/download.php und installieren.
3) WinSCP starten. Es sollte sich ein Anmeldefenster öffnen (wenn man das Anmeldefenster manuell öffnen muss, oben links auf die Registerkarte „Neue Sitzung“ klicken). Unter „Sitzung“ als Dateiprotokoll „SCP“ auswählen. Als Hostnamen die IP-Adresse eingeben, die in Schritt 1 notiert wurde. Die Portnummer unverändert lassen. Als Benutzernamen „root“ eingeben. Als Passwort „1234“ eintragen. Dann auf „Anmelden“ klicken. Es werden ein oder zwei Warnungen angezeigt, in denen man gefragt wird, ob man fortfahren möchte. Diese Meldungen mit Ja bestätigen. Wenn die Fehlermeldung „Fehler beim Abrufen des Namens des aktuellen Remote-Verzeichnisses“ kommt, diese schließen, indem man auf „OK“ klickt.
4) Das WinSCP-Fenster zeigt nun links die Dateien und Ordner des Computers und rechts die Dateien des Squeezebox Radios an. Nun auf der Squeezebox Radio-Seite (rechts) zum Stammverzeichnis navigieren (das ist der Ordner ganz oben in der Hierarchie). Man kann dies tun, indem man auf die Schaltfläche „Wurzelverzeichnis“ klickt, welche über der Dateiliste links neben dem "Heimatverzeichnis" (Haus-Symbol) angezeigt wird. Nun zum Ordner „etc“ navigieren, indem man darauf doppelklickt. Anschließend auf den Ordner "init.d" doppelklicken.
5) Die Datei "wlan" mit der rechten Maustaste anklicken, dann auf "Bearbeiten" und nochmals auf "Bearbeiten"
6) Mit der Pfeiltaste nach unten bis zur Zeile 29 (die Zeilennummer steht ganz unten im Fenster)
In dieser Zeile steht "/lib/atheros/wmiconfig -eth1 --power maxperf"
Hier nun einfach direkt davor ein Rautezeichen (#) schreiben. Also "#/lib/atheros/wmiconfig -eth1 --power maxperf"
7) Oben links auf "Speichern" drücken oder "Strg+S" und eventuelle Fehlermeldung(en) bestätigen bzw. ignorieren.
8) WinSCP schließen und eventuelle Fehlermeldung(en) bestätigen bzw. ignorieren.
9) Neustart des Radios.
10) Um zu kontrollieren, ob das Rautezeichen (#) übernommen wurde, einfach nochmals Punkt 3 bis 5 wiederholen und bei Punkt 6 nachschauen ob der Dateiname nun so lautet: #/lib/atheros/wmiconfig -eth1 --power maxperf
11) Da ich bei mir bereits "wlanpoke" installiert hatte, habe ich das zur Sicherheit wieder deaktiviert, indem ich die Datei "rcS.local" im Verzeichnis "/etc/init.d/" gelöscht habe.
Seit Stunden läuft nun mein Radio ohne Probleme und Abbrüche - ich hoffe sehr, dass es auch so bleibt! :-)
Zudem würde es mich interessieren, ob jemand von euch diesen Fix mit der Ergänzung des Rautezeichens (#) auch schon getestet hat und ob es erfolgreich gewesen ist oder nicht.
kire
Beiträge: 2
Registriert: 24. Juli 2023 17:15
SqueezeBox: Radio
SqueezeBox: UE Smart Radio
SqueezeBox: Classic
SqueezeBox Server läuft auf: Synology DiskStation DS920+

Re: Massive WLAN-Probleme

Beitrag von kire »

Seitdem ich meine neue Fritz!Box 7590 AX nutze, habe ich auch ständig WiFi-Abbrüche beim SB Radio und habe nach der Ursache dafür gesucht. Im Slimdevices Forum wurde kürzlich eine neue Community Firmware veröffentlicht, Version 8.0.1 r16924, die beide bisherigen Workarounds (wlanpoke und Auskommentieren einer Zeile in der WLAN-Konfiguration) überflüssig macht. Es gibt nun eine neue Konfigurationsseite unter

Einstellungen > Erweitert > Netzwerke > WiFi Robustness Options

mit den beiden standardmäßig deaktivierten Optionen
> Enable ARP watchdog
> Disable legacy 802.11b

Falls man bisher wlanpoke genutzt hat, sollte man vor dem Firmware Update ein Factory Reset durchführen.
Weitere Informationen zu den neuen Optionen findet man im Forum...

https://forums.slimdevices.com/forum/us ... ost1641603
Benutzeravatar
holte
Beiträge: 8
Registriert: 12. Oktober 2022 19:44
SqueezeBox: Radio
SqueezeBox Server läuft auf: QNAP-NAS unter QTS 5.0.1

Re: Massive WLAN-Probleme

Beitrag von holte »

Wie "kire" schreibt, ersetzt die aktuelle Version 8.01 r16924 der Community Firmware tatsächlich den Software-Workaround wlanpoke und das Auskommentieren der Zeile 29 in der Datei /etc/init.d/wlan des Squeezebox Radios vollständig.

So hat mein SB Radio ca. einen Tag fehlerfrei funktioniert. Dann allerdings brach die WLAN-Verbindung ab und wurde auch nicht mehr erneut aufgebaut. Komischerweise zeigte das SB Radio in diesem Fall ein blaues WiFi-Symbol an, was eigentlich bedeutet, dass die WLAN-Verbindung funktioniert, aber der Logitech Media Server nicht erreichbar ist. Tatsächliche Ursache waren jedoch wieder Probleme mit vorhandenen WiFi 6 Netzwerken in der Umgebung. Nach einem Neustart des SB Radios wurde die WLAN-Verbindung wieder korrekt aufgebaut.

Nach diesen Erfahrungen bin ich wieder zu meiner Hardware-Lösung zurückgekehrt.
Freundliche Grüße
Thomas Holte 8-)
Benutzeravatar
MarkusLehmann
Beiträge: 12
Registriert: 3. November 2012 21:46
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox Server läuft auf: Windows 11
Wohnort: Wolfach

Re: Massive WLAN-Probleme

Beitrag von MarkusLehmann »

Da ich seit 22.7. durch das Auskommentieren der Zeile 29 in der Datei /etc/init.d/wlan des Squeezebox Radios nun über eine Woche ohne jeglichen WLAN-Abbruch unterwegs bin, werde ich kein Firmware-Update mehr machen. Ich bin einfach nur happy, dass das Auskommentieren den gewünschten Erfolg gebracht hat :-)
Eisbär2
Beiträge: 27
Registriert: 21. Februar 2014 21:48
SqueezeBox: Radio
SqueezeBox Server läuft auf: Synology DS114

Re: Massive WLAN-Probleme

Beitrag von Eisbär2 »

MarkusLehmann hat geschrieben: 22. Juli 2023 21:41 Update 22.07.2023:
Tatsächlich scheint der Workaround "wlanpoke" von POMdev immer noch zu Aussetzern zu führen, komischerweise bei vielen Radiosendern so gut wie gar nicht, bei einigen wenigen dafür fast alle 15 Minuten.
...
Seit Stunden läuft nun mein Radio ohne Probleme und Abbrüche - ich hoffe sehr, dass es auch so bleibt! :-)
Zudem würde es mich interessieren, ob jemand von euch diesen Fix mit der Ergänzung des Rautezeichens (#) auch schon getestet hat und ob es erfolgreich gewesen ist oder nicht.
Seit ich meine neue Fritz!box (5590) mit Wifi 6 habe, habe ich auch ständig die bereits geschilderten Probleme mit dem WLAN. Bei mir tauchen die in der Regel nach spätestens (!) einer Minute auf.

Bin eben deiner Anleitung gefolgt Markus. Und bisher sieht es sehr gut aus. Herzlichen Dank dafür!
wilkman
Beiträge: 1
Registriert: 4. August 2023 14:18
SqueezeBox: Classic

Re: Massive WLAN-Probleme

Beitrag von wilkman »

MarkusLehmann hat geschrieben: 30. Juli 2023 14:16 Da ich seit 22.7. durch das Auskommentieren der Zeile 29 in der Datei /etc/init.d/wlan des Squeezebox Radios nun über eine Woche ohne jeglichen WLAN-Abbruch unterwegs bin, werde ich kein Firmware-Update mehr machen. Ich bin einfach nur happy, dass das Auskommentieren den gewünschten Erfolg gebracht hat :-)
Vielen Dank Markus, bei mir hatte der wlanpoke fix leider auch nicht funktioniert. Nun deinen Workaround probiert und siehe da, bislang funktioniert es problemlos - ohne Abbrüche.

Super, dass du da weiter recherchiert hast. Top!
Benutzeravatar
Markus_the_Great
Beiträge: 74
Registriert: 13. Oktober 2011 21:32
SqueezeBox: Duet
SqueezeBox: Radio
SqueezeBox Server läuft auf: NAS: Zyxel NSA320
+ sporadisch: Win7

Re: Massive WLAN-Probleme

Beitrag von Markus_the_Great »

MarkusLehmann hat geschrieben: 22. Juli 2023 21:41 Update 22.07.2023:
Tatsächlich scheint der Workaround "wlanpoke" von POMdev immer noch zu Aussetzern zu führen, komischerweise bei vielen Radiosendern so gut wie gar nicht, bei einigen wenigen dafür fast alle 15 Minuten.
Auch mein Radiowecker funktionierte nicht immer, häufig hat sich der nervige Standard-Weckton bei fehlender WLAN-Verbindung gemeldet, den ich jetzt mal durch einen anderen Alarmton ausgetauscht habe. Das funktioniert indem man im Radio-Verzeichnis "/usr/share/jive/applets/AlarmSnooze" die Datei "alarm.mp3" durch eine andere gleichlautende "alarm.mp3"-Datei ersetzt, mit einem schöneren Weckton. Sorry für die kleine Abschweifung, aber nichts Nervigeres, als durch einen Ton geweckt zu werden, den man überhaupt nicht ausstehen kann.
Nun bin ich auf diesen Thread von Tony T gestoßen: https://forums.slimdevices.com/forum/us ... disconnect
Anscheinend fehlt wohl nur ein Raute-Zeichen (#) an einer bestimmten Stelle im Pfad "/etc/init.d" in der Datei "wlan"
Ich bin dann wie folgt vorgegangen:
1) Den SSH-Server des Radios aktivieren: > Home > Einstellungen > Erweitert > Remote-Anmeldung > Auswahl von SSH aktivieren und dabei die IP-Adresse des Radios notieren, die auf dem Bildschirm in der folgenden Meldung angezeigt wird.
2) Das Programm "WinSCP" auf den Computer runterladen von der Seite https://winscp.net/eng/download.php und installieren.
3) WinSCP starten. Es sollte sich ein Anmeldefenster öffnen (wenn man das Anmeldefenster manuell öffnen muss, oben links auf die Registerkarte „Neue Sitzung“ klicken). Unter „Sitzung“ als Dateiprotokoll „SCP“ auswählen. Als Hostnamen die IP-Adresse eingeben, die in Schritt 1 notiert wurde. Die Portnummer unverändert lassen. Als Benutzernamen „root“ eingeben. Als Passwort „1234“ eintragen. Dann auf „Anmelden“ klicken. Es werden ein oder zwei Warnungen angezeigt, in denen man gefragt wird, ob man fortfahren möchte. Diese Meldungen mit Ja bestätigen. Wenn die Fehlermeldung „Fehler beim Abrufen des Namens des aktuellen Remote-Verzeichnisses“ kommt, diese schließen, indem man auf „OK“ klickt.
4) Das WinSCP-Fenster zeigt nun links die Dateien und Ordner des Computers und rechts die Dateien des Squeezebox Radios an. Nun auf der Squeezebox Radio-Seite (rechts) zum Stammverzeichnis navigieren (das ist der Ordner ganz oben in der Hierarchie). Man kann dies tun, indem man auf die Schaltfläche „Wurzelverzeichnis“ klickt, welche über der Dateiliste links neben dem "Heimatverzeichnis" (Haus-Symbol) angezeigt wird. Nun zum Ordner „etc“ navigieren, indem man darauf doppelklickt. Anschließend auf den Ordner "init.d" doppelklicken.
5) Die Datei "wlan" mit der rechten Maustaste anklicken, dann auf "Bearbeiten" und nochmals auf "Bearbeiten"
6) Mit der Pfeiltaste nach unten bis zur Zeile 29 (die Zeilennummer steht ganz unten im Fenster)
In dieser Zeile steht "/lib/atheros/wmiconfig -eth1 --power maxperf"
Hier nun einfach direkt davor ein Rautezeichen (#) schreiben. Also "#/lib/atheros/wmiconfig -eth1 --power maxperf"
7) Oben links auf "Speichern" drücken oder "Strg+S" und eventuelle Fehlermeldung(en) bestätigen bzw. ignorieren.
8) WinSCP schließen und eventuelle Fehlermeldung(en) bestätigen bzw. ignorieren.
9) Neustart des Radios.
10) Um zu kontrollieren, ob das Rautezeichen (#) übernommen wurde, einfach nochmals Punkt 3 bis 5 wiederholen und bei Punkt 6 nachschauen ob der Dateiname nun so lautet: #/lib/atheros/wmiconfig -eth1 --power maxperf
11) Da ich bei mir bereits "wlanpoke" installiert hatte, habe ich das zur Sicherheit wieder deaktiviert, indem ich die Datei "rcS.local" im Verzeichnis "/etc/init.d/" gelöscht habe.
Seit Stunden läuft nun mein Radio ohne Probleme und Abbrüche - ich hoffe sehr, dass es auch so bleibt! :-)
Zudem würde es mich interessieren, ob jemand von euch diesen Fix mit der Ergänzung des Rautezeichens (#) auch schon getestet hat und ob es erfolgreich gewesen ist oder nicht.
Super. Klappt bis jetzt auf dem Squeezebox Radio wunderbar!
Funktioniert das auch auf Squeezebox Duet dergleichen?