Puffer Aktualisierungsfehler im lokalen Betrieb

Benutzeravatar
paulplanlos
Beiträge: 5
Registriert: 6. November 2021 04:08
SqueezeBox: Touch
SqueezeBox Server läuft auf: Toshiba Satellite L300-218 / Win 10 / LMS 8.2.0

Puffer Aktualisierungsfehler im lokalen Betrieb

Beitrag von paulplanlos »

Moinsen,
ich bin Sascha, 47 Jahre, Techno-Freak, Bastler, Squeezebox-Fan seit 2010.

Ich habe meine Squeezebox Touch mit einem alten XP-Rechner als Server ca. 6 Jahre problemlos betrieben.
Dann fing es irgendwann an mit willkürlichen Aussetzern.

Die Musik hört plötzlich auf zu spielen – der Remaining Timer des Songs springt auf ca 50 Minuten hoch und nach ca 20-30 Sekunden Stille erscheint „Puffer Aktualisierungsfehler“ auf dem Display. Die Musik läuft dann an der Stelle weiter wo sie aufhörte.

Mal passiert es alle 30 Minuten - dann wieder 4 Stunden ohne Probleme – völlig unberechenbar.
Es hat leider nichts mit der einstellbaren Puffergrösse für Internetradio in den Serveroptionen zu tun. Ich benutze die SB-Touch wegen dem alten XP-Rechner ausschliesslich nur noch im lokalen Netzwerk.

Was ich zuerst ausprobiert habe:
Nachdem ich ein bischen im Forum gelesen hatte habe ich erstmal ein neues Netzteil besorgt. (klang plausibel für mich – Spannung bricht ein – Datenstrom wird unterbrochen) Aber da das nichts veränderte, packte ich erstmal alles für eine Weile beiseite.

Mein Hauptargument dass ich meine SB-Touch nicht schön längst verkauft habe ist die tolle Bedienbarkeit mit der SqueezeControl-App (von angryGoat) und das für mich bisher unerreichte Gapless Playback

Nun habe ich nochmal 4 Tage Lebenszeit mit der Squeezebox verbracht.
Was ich jetzt ausprobiert habe:

Betrieb nur über Kabel im LAN

Sämtliche Softwarekombinationen (Server und Client) von SqueezeServer 7.6.0. bis Logitech Media Server 8.2.0
Ich habe Logfiles beobachtet bis der Fehler auftrat. (hier fehlt mir sicher inhaltlich der Durchblick und ich weiss nicht welche Quellen alle relevant für das Fehlerbild sind)
In meinen ausgewählten Logfiles sah ich jedenfalls mehrere Anfragen an den Server von anderen Geräten im Haus (TV-Geräte, Pioneer Verstärker, Handy usw…) und habe dann die IP’s auf die nötigen Geräte eingegrenzt (Server, SB-Touch, Handy) und auch das Weglassen der SqueezeControl-App vom Handy hatte keine verbessernde Auswirkung.

Ich habe Prozessor- und Netzwerkauslastung des Servers beobachtet bis der Fehler auftrat. (Der Server schien völlig unbeeindruckt - keine Einbrüche oder Sprunghaftes Nachladen ersichtlich, auch kein Anstieg der Prozessorauslastung)

Meine Vermutung war, daß die SB-Touch intern ein Problem hat - dagegen spricht aber mein letzter Versuch, bei dem ich im serverlosen mysqueezebox.com-Betrieb mit Internetradio keinerlei Ausfälle produzieren konnte.

Hat da jemand noch eine Idee?
Welche Logs sind wirklich interessant für dieses Problem – und welche kann ich sicher weglassen?
karlek
Moderator
Beiträge: 2038
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Puffer Aktualisierungsfehler im lokalen Betrieb

Beitrag von karlek »

paulplanlos hat geschrieben: 6. November 2021 15:02 Welche Logs sind wirklich interessant für dieses Problem – und welche kann ich sicher weglassen?
Irgendwie klingt es ja dann doch nach einem Problem mit dem XP-Server.

Ich würde mal die Protokolle, die mit network beginnen auf Warnungen oder Informationen stellen, wobei Du auf repositories und squeezenetwork vermutlich verzichten könntest.

Weiter sieht es so aus, als liefe bei Dir ein DLNA/uPnP-Server mit auf dem Rechner oder sogar im LMS. Den würde ich auch mal ausschalten.
Benutzeravatar
paulplanlos
Beiträge: 5
Registriert: 6. November 2021 04:08
SqueezeBox: Touch
SqueezeBox Server läuft auf: Toshiba Satellite L300-218 / Win 10 / LMS 8.2.0

Re: Puffer Aktualisierungsfehler im lokalen Betrieb

Beitrag von paulplanlos »

karlek hat geschrieben: 7. November 2021 17:03 Weiter sieht es so aus, als liefe bei Dir ein DLNA/uPnP-Server mit auf dem Rechner oder sogar im LMS. Den würde ich auch mal ausschalten.
Ah.. ja - deswegen die Zugriffe von den anderen Geräten... OK

Ich habe gestern mal einen älteren Win10 Laptop mit LMS 8.2.0. eingerichtet.
Läuft bisher ohne Aussetzer. Also Freispruch für die Squeezebox-Touch - die ist unschuldig.

Dann muss der alte Dell ja irgendein Problem entwickelt haben, Denn auch mit einem Festplatten-Image aus problemlosen Zeiten
gibt es Aussetzer - bei unveränderter Hardware.

Dann eben mit Laptop - Hauptsache die Squeezebox wird endlich wieder genutzt :D
(Ist wohl auch besser mit nem aktuellen System)
Benutzeravatar
paulplanlos
Beiträge: 5
Registriert: 6. November 2021 04:08
SqueezeBox: Touch
SqueezeBox Server läuft auf: Toshiba Satellite L300-218 / Win 10 / LMS 8.2.0

Re: Puffer Aktualisierungsfehler im lokalen Betrieb

Beitrag von paulplanlos »

Natürlich zu früh gefreut :shock:

Auch auf dem Laptop jetzt Puffer Aktualisierungsfehler

Ich habe mal ein Server Log angehängt.
Ab [21-11-08 15:01:10.0768] geht es los mit "Puffer wird aktualisiert...0%"
server.log
(am besten im Editor nach "Puffer" suchen)
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Benutzeravatar
paulplanlos
Beiträge: 5
Registriert: 6. November 2021 04:08
SqueezeBox: Touch
SqueezeBox Server läuft auf: Toshiba Satellite L300-218 / Win 10 / LMS 8.2.0

Re: Puffer Aktualisierungsfehler im lokalen Betrieb

Beitrag von paulplanlos »

Nach weiterer endloser Nachdenkerei und Herumprobiererei glaube ich nun wieder einmal der Lösung auf der Spur zu sein :D
(bis ich wieder eines Besseren belehrt werde)

Immer wenn ich dachte: es funktioniert jetzt - dann war es eine nackte Installation des LMS auf einem frischen Windows System ohne irgendwelche 3rd party plugins und Schnick Schnack.

:idea: Eines meiner immer installierten Standard Plugins ist "ServerPowerControl"
Damit kann man übers Menü bequem den Server in Standby, Hibernate oder Restart schicken.
Nebenbei verhindert das Plugin auf Wunsch auch ein ungewolltes Standby indem es den Idle Status des Netzwerks überwacht und durch Senden von Paketen den vorzeitigen Standby verhindern kann. Hört sich nach Eingriff in Netzwerk und Datenverkehr an...

Also Plugin deaktiviert und seitdem keinen Puffer-Aktualisierungsfehler mehr gesehen.
Glauben tu ich's zwar immer noch nicht - aber hoffen darf man ja.

Ich melde mich wieder...
Benutzeravatar
paulplanlos
Beiträge: 5
Registriert: 6. November 2021 04:08
SqueezeBox: Touch
SqueezeBox Server läuft auf: Toshiba Satellite L300-218 / Win 10 / LMS 8.2.0

Re: Puffer Aktualisierungsfehler im lokalen Betrieb

Beitrag von paulplanlos »

Tach auch..
um dieses Thema erstmal abzuschliessen...

Bei mir hat es geholfen das Plugin "ServerPowerControl" und das zugehörige "SCPowerTool" nicht zu installieren.
Die Squeezebox Touch läuft nun seit 53 Stunden im Dauerbetrieb fehlerfrei.
karlek
Moderator
Beiträge: 2038
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Puffer Aktualisierungsfehler im lokalen Betrieb

Beitrag von karlek »

Das freut mich, dass Du die Ursache (vermutlich) gefunden hast. Vielleicht findest Du im slimdevices-Forum mehr darüber. Der Entwickler des Plugins ist dort ab und zu noch aktiv.

Ich fand es auch super, dass Du hier Protokoll geführt hast. Ich habe fleißig mitgelesen. Auf ein Plugin hätte ich eigentlich kommen müssen, aber irgendwie bin ich gerade ein wenig raus. Bei mir läuft alles problemlos. :)